Home > Hardware and Software, Ventrilo, Windows Vista > FIX: Ventrilo 2.3.0 and Vista Press-to-Talk Fix

FIX: Ventrilo 2.3.0 and Vista Press-to-Talk Fix

March 11, 2007

Over the past few months, I’ve “tolerated” an inconsistant bug with Ventrilo and Vista—the inability to use my press-to-talk (PTT) key while in another window, like EverQuest 2.  I would constantly alt-tab in and out of the game, which made raid leading an… experience in button smashing.  Last night, I stumbled upon a couple of forum posts that list a few fixes:

http://www.ventrilo.com/forums/showthread.php?t=14980

http://www.ventrilo.com/forums/showthread.php?t=17210

It lists three things to check:

  1. Set Ventrilo to “Run as administrator”
  2. Set Ventrilo to emulate Windows XP SP2.
  3. Set your game, EQ2, to “Ignore Windows Hotkey”

For me, the winner was #1, setting it to run as an administrator.  #2 and #3, tried both separately and together, did not resolve the issue; however, #1 separately does.  Just seems odd.  I have to run EQ2 as administrator, Ventrilo, Visual Studio… UAC is defeated a BIT by just automagically turning “run as administrator” on for every program.  <shrug />

Ttchnorati Tags: , , ,

  1. TJ
    May 22, 2007 at 12:33 am

    A combo of #1 and #2 fixed my issues — thanks!

  2. know|edge
    July 22, 2007 at 5:58 pm

    #1 worked for me also…seems like you have to run everything as admin in vista..might as well disable VAC.

  3. July 22, 2007 at 8:56 pm

    Glad it’s working. I still haven’t disabled UAC; probably cause I’ve become immune to the annoying popup messages. I keep holding out hope (*laugh*) that there’s some added benefit or it’s protected me against SOMETHING.

    Ahh, the life of an optimist.😉

  4. September 16, 2007 at 8:59 pm

    BOO EQ2! You should play WoW instead.😉 However, thank you for posting this blog. It helped.

  5. September 16, 2007 at 9:22 pm

    LOL, actually playing FFXI now. EQ2 got kinda dull and all my friends left.😦

    Tried WoW… it’s okay, but never captured my attention.

    Glad the post helped!

  6. Thergore
    October 8, 2007 at 9:05 pm

    OMG this has helped. Running Vent in WoW I’ve had no problems, but switching over to Eq2, this hasn’t been working for me at all. Thanks for posting this fix!!

  7. December 30, 2007 at 10:06 pm

    This fix was my lifesaver! I’m a WoW player, and started using ventrilo when my guild started doing raids, and I couldn’t figure out why I couldn’t talk in-game. The whole ‘run as administrator’ idea worked like a charm, and I felt really stupid after spending an hour trying to figure out how to fix it.

    Thanks for posting this fix, much appreciated by us WoW nerds who have the inconvenience of using Windows Vista as an operating system.

  8. Craig Matthews
    January 17, 2008 at 9:11 pm

    THANKS!!!!!! U Rock.

  9. stc
    March 19, 2008 at 6:48 pm

    please someone can you explain me those 3 kind of easy i have the same problem😦

  10. Rosati
    April 2, 2008 at 3:30 pm

    I have tried both things and it still won’t let me connect. I can’t even get it to pop up on my screen to let me hit the connect button and it was workig just fine a few days ago. Its on my taskbar at the bottom and I can see that its running. Any ideas? I have tried all the things that u have listed.

  11. Remedith
    November 23, 2008 at 8:23 am

    Tnx a lot !!! #1 solved the prob at once😀 tnx !

  12. Star
    January 25, 2009 at 3:34 am

    Do you, by any chance, have a solution to getting vent to work with Perfect World International as well? It’s difficult when I’m trying to do FB’s and I can’t reply because I have to stop what I’m doing and open the vent window just to talk. I’m a healer, so I can’t just stop healing… Y’know? So, if there’s a fix for that, I would be more than happy to try it.

  13. Elidhuu
    April 13, 2009 at 9:29 pm

    I tried EVERYTHING it will not work :(:( I even opened ports on my router and such… my problem is that it keeps staying on “msg: synchronizing” or whatever and wont connect. I really need help. I can connect at my boyfriends house but nto at mine… I think its my router. Any help would be appreciated thanks so much🙂 Also, is it allowed to use the older version of vent? I wonder if that would work… because a lot of people are having the same problem as me that didn’t have this issue on the older versions. Please provide a link to the download if possible. Thanks so much🙂

  14. Alowicious
    May 20, 2009 at 6:38 pm

    I have tried all three and done several other things but my push to talk will work fine for the test but wont light up green even when theres no other programs running… I’ve even re-installed the older version but it still isnt working.. any ideas?

  15. godmode
    June 11, 2009 at 8:26 am

    Can someone help me with this problem. When i use vent and i push to talk, the key locks up and will hold the push button for a really long time. I’ve reinstalled several times and tried all those options. Any advice>

  16. kizzie
    August 10, 2009 at 11:34 am

    FINALLY! an answer that worked! Thank-you! Dumb guildy just told me to uninstall…

  1. April 14, 2008 at 10:18 pm
Comments are closed.
%d bloggers like this: