Home > EverQuest 2, Final Fantasy XI, Ventrilo, Windows Vista > Ventrilo 3.0.1 Client and 3.0.2 Server

Ventrilo 3.0.1 Client and 3.0.2 Server

November 19, 2007

Well, that didn’t take long… 3.0.0 has come and gone with Ventrilo as the team released updates to both the server and client software early this week.

The client changes, as you can read below, seem mostly aestetic; however, I’m sure hosting companies are pleased to see some of the fault issues fixed in 3.0.2.

Here’s the changes:

Version 3.0.2 Server only:

Fixed exception fault when loading a damaged channel file.

Fixed private chat replicating problem. Pro server only.

Modified Account management so that it is harder to lock your self out of the server.

Server Admin->Login will now give complete rights like 2.3 did. With the exception of Edit Voice/Cmd targets which are user account specific anyway and Pro server only.

Upgrading a 2.3 to 3.0 server will automatically assign full admin rights to an old account that already had the server admin right.

Modified USR and TRG files to be automatically updated in 1 minute instead of 1 hour.

Fixed server name length to be a minimum of 2 characters instead of 4.

When upgrading a 2.3 server to 3.0, or creating a new 3.0 server from scratch, the server will assume Duplicate IP’s settings of “No Limit”.

Version 3.0.1 Client only:

User Editor: Made current user list window wider and added support for horizontal scroll bar when needed.

User Editor: Pressing new button will now default Duplicate IP’s to No Limit.

User Editor: Generic User and Generic admin profiles now default Duplicate IP’s to No Limit.

User Editor: Removed feature where clicking on an existing account name in the main window would cause a selection change in the UE Window. While useful in some cases it creates more problems that it solved. Might make this an option in a future version.

Main Window: Display of the (GUEST) tag is now off by default. Can be turned on via new menu option View -> Guest tags.

Guest MOTD: Now provides option to display only if it changes.

Chat: Time stamp option will now display correct month number.

Menu: When paired with 3.0.2 server, using the Server Admin -> Login will now allow certain menu items to be usable instead of grayed out.

You can download (and install over your existing installation) here.  Looks like hosting companies, like NationVoice, are still at 3.0.0.  Hopefully this will change in the next few days.

From my server logs:

20050325 01:43:50 Version           = 3.0.0

Then again… why does it think it’s 2005.  *boggle*

Tags: ,
  1. nick
    November 30, 2007 at 3:18 pm

    hey how do i get 2 log on my vent 2 work it saids Server is running version 3.0.2

  2. louis
    November 30, 2007 at 4:14 pm

    I dont know how to download ventrilo 3.0.2 . How does i do that?

  3. November 30, 2007 at 4:41 pm

    @nick – If your server is running 3.0.2; you’ll need version 3.0.1 of the client.

    You can download it here.

    http://www.ventrilo.com/download.php

  4. November 30, 2007 at 4:42 pm

    @louis – You can download Ventrilo 3.0.1 CLIENT or 3.0.2 SERVER from http://www.ventrilo.com/download.php.

  5. Kevin
    December 14, 2007 at 9:09 pm

    I have the 3.0.1 CLIENT and im trying to connect to a 3.0.2 SERVER but it wont let me. It says i need to update my client to 3.0.2. I beleive this is because i have vista home edition, any suggestions? Running as administrator didn’t work either…

  6. December 19, 2007 at 7:15 pm

    Yeah 3.0.1 client WILL NOT CONNECT TO 3.0.2 server, hmm looks like Ventrilo needs to think before they speak. this is leaving me hanging with my 50 person clan without my ventrilo server.

  7. December 19, 2007 at 8:18 pm

    @Kevin/@Vents-

    I wish I had a good answer for you. I’m using NationVoice for our guild/linkshell chats and when I look at the logs (and I’ve verified by their technical staff), we’re on version 3.0.2 server:

    Version = 3.0.2

    I’m running the client 3.0.1 on Windows Vista Ultimate x64. It connects without any problems. I am running the application as administrator (since it’s Vista), but there aren’t any other configuration snafus past that.

    Check out this post on the forums regarding firewall issues–maybe that’s it. I explicitly allowed Ventrilo on the Windows firewall.

    http://www.ventrilo.com/forums/showthread.php?t=23257

    Beyond that, my recommendation would be to post it up (or maybe find an existing post) that matches your issues. The Ventrilo forums are pretty active:

    http://www.ventrilo.com/forums/forumdisplay.php?f=4

    Good luck!

  8. Leon
    December 24, 2007 at 2:17 am

    This whole thing is a pandemic in my opinion.I mean, people like kevin have some big crap to do on vent, and we can’t get on. I personally run a guildwars clan of the max 100 people. In terms of vent, its a riot, but we still need it. I’ not saying it’s anyones fault, but obviously firefox or whoever makes these vent announcements and servers, needs to get another job because they suck at keeping the peace.

    This was your man Leon, keeping the facts alive.

  9. Leon
    December 24, 2007 at 2:18 am

    My bad, ventbullshit is who i meant, not Kevin, sorry dude

  10. Patrik
    December 26, 2007 at 12:28 pm

    Hello when i try to connect to ventrilo nothing happens it starts to work like i´m about to get into vent but then nothing happens i can press disconnect and the sound off when you disconnect going threw my ears i added ventrilo to my firewall but it still doesn´t work do you think it can be something about my router or something? really happy if you respond thanks/ Patrik

  11. Tommy-André
    February 14, 2008 at 6:29 pm

    Hi, i want to host a public ventrilo server, and i got linux as my OS..
    And the limit of people on the server is 8… Can someone help me with a program for linux, so i can set it up to 1000 or something ?

    Email: tommyen@skallebank.com

    thank you for answering and thank you for your time

    Tommy-André Pettersen

  12. Tommy-André
    February 14, 2008 at 6:29 pm

    Set the limit up to 1000 or something**
    🙂

  13. February 14, 2008 at 6:33 pm

    @Tommy-André-

    Unfortunately, you can’t with the public version. To setup more, you’ll need the pro version with requires a contract agreement and service agreement with Ventrilo. They do this to attempt to control and regulate how their servers are run to be certain, I’m assuming, they meet certain quality standards.

    More info at : http://www.ventrilo.com/purchase.php

  14. CvBxPhan
    March 8, 2008 at 7:20 am

    Hi can u please tell me how to establish my own vent server on window vista cause each time i run vent server it dont give me a ip or any other information.. pleace e-mail me at Azn_boi_251@yahoo.com

  15. June 14, 2008 at 1:41 am

    VENTRILO 3.0.2 Wont work its there fukin fault and there a bunch of diks

    TELL ME WHEN ITS FIXED PLZ

  16. June 14, 2008 at 8:08 am

    @3litepker-

    Vent 3.0.2 works just fine; I and my entire linkshell as well as all my friends on EQ2 use it almost every night. I’d suggest inspecting your computer’s configuration to ensure your sound input device (headset or boom mic) is configured as the default sound device and that you’re running Vent as the administrator (if Vista).

  17. InSpil2e
    August 16, 2008 at 12:01 am

    Is there anyway to keep my vent server running even after i shut down my computer even though it requires me to keep: Ventrilo Server program on 24/7 to keep my vent running 24/7 or else everytime i shut down my computer my vent stops working.

  18. Joost
    August 22, 2008 at 6:35 am

    Hi
    I have a weird problem with v3.0.
    My OS is Vista.
    For the guild we use V3.0, I have no problems with connecting.
    However when I don’t have ventrilo open, I can’t talk. What I mean is as soon I start up a game(WoW) or anything that puts ventrilo on the background I’m not able to talk/ people don’t hear me. So everytime I need to go back to my desktop to be able to talk.

    Anyone else had the same problem? I already re-instaled programs but nothing helped. Also Windows won’t help since ventrilo is not a MS software etc.

    Thanks
    Joost

  19. August 22, 2008 at 6:39 am

    @Joost-

    Yeah, run Ventrilo as an administrator under Vista, then the PTT keys will pick up, even if Ventrilo isn’t modal.

  20. Joost
    August 22, 2008 at 4:05 pm

    ! Damn that was to easy.

    I was informing it for a Gmate, he said he already tried that but apperntly not…

    Big thanks, you safed him a demote🙂.

  21. Hobbe
    August 26, 2008 at 4:58 pm

    Wzup!? i had the same problem as joost… Thanks for the help David it works just fine now😀

  22. kaarle
    September 13, 2008 at 12:13 am

    Hi, I have recently set up a vent server, everything’s cool, I’ve got my channels up and running and all is well…
    except everytime I shut down my comp the vent shuts down aswell…
    is there a way that you know to keep the server up an’ runnin’ even though the computer the server is hosted with is shut down?
    THanks in advance

    Kaarle

  23. September 13, 2008 at 6:46 am

    @kaarle-

    Unfortunately, no. Ventrilo is an application just like any game or Microsoft Word–when the computer isn’t on, neither is it.

    For a while, I hosted my own Ventrilo server (for our EQ2 group) using a REALLY old computer that I just sat down in the basement next to the cable modem. Five connections were enough at that time (that’s the limit, or at least was back then for the ‘free’ version).

    After that, we HAD to host it to get 24/7 access and the 100ish connections we needed. NationVoice was a sweet host (though kinda pricey).

  24. Dichard
    November 4, 2008 at 3:39 pm

    you have any idea why i cant hear people on ventrilo? i have scanned my computer, removed programs that is new on my computer, reinstalled the ventrilo, made a new user on vent etc… have used ventrilo for over a year, and when i tried to use it yday.. i could see that people were speaking, but was no sound.. !!

    any idea?

  25. November 4, 2008 at 3:41 pm

    @Dichard-

    Check to make sure that your sound output device is what you expect. I bounce between a Logitech USB headset and speakers and find that sometimes Ventrilo isn’t smart enough to realize that I ALWAYS want the USB headset.

  26. November 4, 2008 at 4:01 pm

    thnx

  27. Dichard
    November 4, 2008 at 4:01 pm

    atm it stand on Default wave maps…and “user direct sound” aint enabled…
    i can choose between “default wave maps” and ” headset(high def”

  28. Dichard
    November 5, 2008 at 9:17 am

    you dont know?😮😦

  29. November 5, 2008 at 9:44 am

    @Dichard-

    Didn’t realize that was a question.😉

    You should choose whichever one your output device is… The Default Wave Mapper would be whatever the current Playback Output device is in Windows. I’m assuming your Headset is… well, your headset. Choose whichever one you’re wanting the sound to come out of.

    You can also do the playback test (lower left-hand corner of that screen) and record yourself and play back to ensure it’s working.

  30. Dichard
    November 5, 2008 at 10:36 am

    hehe😀

    tested the playback etc…

    but, do you know why i cant hear people on vent.. as i said earlier :s
    all info stands there.
    really annoys me, cuz if i dont get it workin, i will have to stop playing my RP Game😦

  31. November 5, 2008 at 10:47 am

    If you can hear yourself on the playback, then the audio device is working. Do you have another vent server you can connect to check?

    Do you have sound muted (on the Vent main screen, down at the bottom is a mute button)?

    I’m not sure if an admin can globally “deaf” someone–I know they can mute people… but a thought.

  32. Dichard
    November 5, 2008 at 11:22 am

    omg! TY!

    was that easy, had muted ventrilo on vent screen! ty!😀

  33. *ZuT*
    November 24, 2008 at 5:30 am

    Alright ive read over all these posts and found nothing that actually helps me with my problem… I am trying to run my own free vent server so me and a game buddy can Vchat… but when I try to connect it stays at the “MSG:Contacting server” screen on the vent itself, ive checked my firewall and allowed both the server and the vent, but it still seems to stick. Can someone please help me…?

  34. Jarge
    June 1, 2009 at 6:41 pm

    Would someone please be able to help me with this problem.
    I have recently started administrating a ventrilo server, V 3.0.4 currently.
    I am having problems using the record/playback function in the binds.
    I have assigned a hotkey to record, stop recording and playback – but when I hit the key for playback, I get no sound.
    How can I get this to work?
    Regards
    Jarge

  35. Meru
    June 30, 2009 at 1:38 pm

    I have a question…I have set up my own vent server on my home computer. I have everything set properly connection wise, as my friends can connect , and etc…my problem is that no one can hear eachother…I have the transit settings rigth ( set so that no one is globally muted etc…) so I really cannot figure it out at all….

    I have win xp home,and a sb 24 bit live! sound card… for some reason I think its related to either the sound card, or my vollume settings in general perhaps?

    any help would be very very much appreciated ( and no I do not have vent muted at the bottom lol )

  36. Phirefly
    July 14, 2009 at 7:43 am

    Hey I use vent for multiple games. When I connect to any server for the first time it tends to nearly freeze the whole computer for nearly 2-5 seconds+. I run of WinVista x64 Home Premium. Definitly have the connection speed/system memory to run Vent and a Video Game. I have check both the standard WinDefender Fire wall and my stay alone Kaspersky’s firewall and the both exclude Ventrilo and the games i play. The same freeze affects WoW… This is somewhat recent. Hopefully someone can help!

    thanx
    Phire

    • July 23, 2009 at 7:49 am

      Are you using DirectSound? If I under stand correctly, this happens whether or not Wow/Vent are open at the same time (e.g. you can open one or the other and it still occurs).

      The only thing I can think of that’s common between them is DirectSound (open Ventrilo, Settings, and in the upper-right corner it should tell you). DirectSound allows you to control the volume of incoming speakers, etc. in Vent.

      Try turning that off and see if Vent works. If it does, try WoW. WoW (afaik) can’t turn off DirectSound, so it should still lock up. If so, perhaps try reinstalling DirectX (which includes DirectSound)… maybe a library has gotten corrupted.

  1. No trackbacks yet.
Comments are closed.
%d bloggers like this: